With the release of 9.1, we have introduced much-needed improvements to the way App Version targeting works. 

This means, however, that versions of your app that use SDK versions before 9.1 will still have to work within those old limitations. This article explains those limitations.

When you create a new survey or announcement and add an App Version condition, you will see a dropdown that contains all versions detected by our SDK. For versions that use SDK versions before 9.1, you will see them grouped by a label that says "App versions prior to SDK V9.1". 

For these versions, note the following:

  • You can't use the operators Greater Than or Less Than if your version is alphanumeric (contains both letters and numbers)
  • You can't target your survey/announcement by Build Number (or Version Code for Android) - only App Versions will be visible in the dropdown 

For the new versions however, these limitations have been lifted, so that:

  • You can now use any combination of operators regardless of what the App Versions contains 
  • You can target by Build Number (or Version Code for Android), with each build having an item in the dropdown 

I added a new version but I don't see it in the dropdown. What's going on?

The first time our SDK detects a new build that doesn't match our data, it gets added to the list of builds associated with your app. This process might take up to 10 mins. If you're still having an issue, contact our support team and we'll be glad to help.

Did this answer your question?